EIGRP演示实验

  • A+
所属分类:Route

EIGRP试验演示:

注意事项:

①:Network命令以及通配符;
②:关闭eigrp的自动汇总;

EIGRP演示实验

EIGRP演示实验

R1基础配置:

Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#interface f0/1
R1(config-if)#ip add 192.168.12.1 255.255.255.0
R1(config-if)#no sh
R1(config-if)#interface f1/0
R1(config-if)#ip add 192.168.13.1 255.255.255.0
R1(config-if)#no sh
R1(config-if)#interface f0/0
R1(config-if)#ip add 10.10.10.254 255.255.255.0
R1(config-if)#no sh

R2基础配置:

Router>en
Router#conf t
Router(config)#host R2
R2(config)#interface f0/1
R2(config-if)#ip add 192.168.12.2 255.255.255.0
R2(config-if)#no sh
R2(config-if)#interface f0/0
R2(config-if)#ip add 192.168.234.2 255.255.255.0
R2(config-if)#no sh
R2(config)#interface f1/1
R2(config-if)#ip add 172.23.23.254 255.255.255.0
R2(config-if)#no sh

R3基础配置:

Router#conf t
Router(config)#host R3
R3(config)#interface f1/0
R3(config-if)#ip add 192.168.13.3 255.255.255.0
R3(config-if)#no sh
R3(config-if)#interface f0/0
R3(config-if)#ip add 192.168.234.3 255.255.255.0
R3(config-if)#no sh
R3(config-if)#interface f1/1
R3(config-if)#ip add 172.23.23.3 255.255.255.128
R3(config-if)#no sh

R4基础配置:

Router>en
Router#conf t
Router(config)#host R4
R4(config)#interface f1/1
R4(config-if)#ip add 192.168.234.4 255.255.255.0
R4(config-if)#no sh
R4(config-if)#interface f0/0
R4(config-if)#ip add 172.28.12.254 255.255.255.0
R4(config-if)#no sh

R1 EIGRP 配置:

R1(config)#router eigrp 100
R1(config-router)#no auto-summary (不连续子网情况下,需要关闭自动汇总)
R1(config-router)#network 10.0.0.0 (按照网段分类进行匹配)
R1(config-router)#network 192.168.12.0
R1(config-router)#network 192.168.13.0

R2 EIGRP配置:

R2(config)#router eigrp 100
R2(config-router)#no auto-summary (不连续子网情况下,需要关闭自动汇总)
R2(config-router)#network 192.168.12.2 0.0.0.0 (精确匹配IP)
R2(config-router)#network 192.168.234.2 0.0.0.0
R2(config-router)#network 172.23.23.254 0.0.0.0

R3 EIGRP 配置:

R3(config)#router eigrp 100
R3(config-router)#no auto-summary (不连续子网情况下,需要关闭自动汇总)
R3(config-router)#network 192.168.13.0 0.0.0.255
R3(config-router)#network 192.168.234.0 0.0.0.255
R3(config-router)#network 172.23.23.0 0.0.0.127 (按照子网掩码精确匹配)

R4 EIGRP 配置:

R4(config)#router eigrp 100
R1(config-router)#no auto-summary (不连续子网情况下,需要关闭自动汇总)
R4(config-router)#network 192.168.234.4 0.0.0.0
R4(config-router)#network 172.28.12.0 0.0.0.255

补充:Router(config-router)#network 0.0.0.0在路由器上所有接口开启EIGRP

除非注明,Byrd's Weblog文章均为原创,转载请以链接形式标明本文地址

本文地址:http://www.t4x.org/route/eigrp-demonstration-experiment/

扩展阅读:《OSPF配置演示

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: